Installazione INFOCENTER su Alfa 156 1ª serie ('97-'01)

BladeGTA

Alfista Esperto
20 Novembre 2007
5,620
141
64
39
Ro
Regione
Veneto
Alfa
156 Sw GTA
Motore
3.2 V6 24v
Re: computer alfa 156

Sarebbe molto interessante vedere la temperatura motore,nonchè fa figo... :) Il contakm della GTA è fondo nero illuminazione rossa e segna 300 km/h,mentre il mio originale è fondo argentato con scala 240. la metodica di misurazione è lka stessa perciò non ho avuto problemi ad interfacciarlo,segna anche giusto tra l'altro. Se mi dai una guida su come collegare il sensosre,volentieri ti ringrazio molto.
 

Riccardo9710

Nuovo Alfista
9 Gennaio 2008
1
0
1
to
Regione
Piemonte
Alfa
156
Motore
1.9 jtd 110Hp
Re: computer alfa 156

carissimo ironman, io sto effettuando proprio in questi giorni la modifica del computer di bordo sulla mia 156 (anno 2001)! come ho finito ti farò sapere le modifiche particolari da fare ma ti garantisco che non serve nulla di strano. logicamente non tutte le funzioni saranno attive ma gran parte e senza particolari accorgimenti funzionano. ciao
 

IRONMAN

Alfista principiante
15 Aprile 2006
114
0
23
37
TO
Regione
Piemonte
Alfa
GTV
Motore
2.0 twin spark
Re: computer alfa 156

carissimo ironman, io sto effettuando proprio in questi giorni la modifica del computer di bordo sulla mia 156 (anno 2001)! come ho finito ti farò sapere le modifiche particolari da fare ma ti garantisco che non serve nulla di strano. logicamente non tutte le funzioni saranno attive ma gran parte e senza particolari accorgimenti funzionano. ciao

bhe,grazie mille....se riesci anche a documentare con delle foto sarebbe perfetto!!!!
 

peppealfa156

Nuovo Alfista
9 Febbraio 2008
26
0
1
TA
Regione
Puglia
Alfa
156
Motore
1.8 TS
Re: computer alfa 156

Ciao ragazzi sono un nuovo iscritto del forum...ho seguito questo post perchè mi interessava.
Vi dico subito che ho montato l'infocenter su alfa 156 1.8 TS - 1° Serie.
L'installazione è semplicissima e la maggior parte dei collegamenti (Porte ANT. e POST. DX e SX, Baule, Alimentazione diretta e sottochiave e massa) vanno fatti al check centrale tra il tachimetro e il contagiri. Il pin per la temperatura olio motore (Solo per GTA - io non ho il sensore) non è collegato. I 4 pin per i tasti di controllo (+/-/info/set) me li sono installati a modo mio a parte. Il pin per il seriale con il climatizzatore l'ho collegato a un pin della centralina clima denominata M70 (dove avete le tre manopole..per intenderci) - questo pin e lo stesso utilizzato per la diagnosi del M70 e serve a trasmettere la temperatura esterna e segnalazione strada ghiacciata. Poi c'è un pin per l'interrutore inerziale. Và portato fino all'interuttore posto sotto al sedile guida- quando scatta l'interuttore l'infocenter lo segnala.

L'unico pin...ripeto l'unico che non posso collegare a nessuna parte e quello denominato "Seriale con tachimetro"!!! Questo influiva sul Trip Computer e quindi non posso avere le informazioni relative a velocità media, consumo, ecc., cioè quelle raggiungibili dal tasto SET !!

Sapete quindi qual'è la fregatura??? Il vero computer è il tachimetro della 2° serie !!!
Infatti a differenza di quello prima serie, Bypassa i segnali dello strumento carburante per farsi i suoi bravi calcoli e sputarli all'Infocenter.
Il Contagiri non è importante, ma il fatto sapete qual'è?? Se cambio il tachimetro devo mettere per forza quello con la luce rossa e faccio il quadro di picasso tra verde e rosso, sfondo bianco e sfondo nero. Dovrei cambiare inutilmente anche gli altri !

Cmq per il momento non fa niente !! Mi piace lo stesso. Ho tutte le informazioni tranne il Trip.

Mi interessava trovare gli At-commands seriali per capire come dialoga il pin seriale techimetro. Se qualche cervello si vuole unire...

Grazie e ciao.
 

tazionuvolari

Alfista principiante
26 Febbraio 2007
102
0
16
AG
Regione
Sicilia
Alfa
159
Motore
1.9 Jdtm SW
Re: computer alfa 156

Mi aggiungo alla discussione rincuorato dal post di peppealfa156...
Infatti, da un pò di tempo ho acquistato su ebay buona parte della strementazione mancante alla mia 156 (1ª serie) che avrei sempre voluto montare.
In particolare ho il computer (penso della giugiaro) e tutta la strumentazione (fondo nero e illuminazione rossa) della 2ª serie (abbastanza recente, penso del 2004).
Inutile dire che ho pure comprato il volante con i comandi radio (in radica e alluminio.... x me 1 vera figata) ..... a volte penso che avrei speso meno a ricomprare una nuova 156.... ma cmq andiamo oltre.
Il problema della strumentazione è che cambiando il tachimetro le spie non coincidono + e mi è comparso l'errore all'airbag.
Visto il messaggio di peppealfa156 sono molto tentato di riprovare a montare tutto ma non so se il problema del tachimetro e relative spie è superabile.
Ciao a tutti.
 

BladeGTA

Alfista Esperto
20 Novembre 2007
5,620
141
64
39
Ro
Regione
Veneto
Alfa
156 Sw GTA
Motore
3.2 V6 24v
Re: computer alfa 156

Purtroppo ragazzi,le spie cambiano perchè nella prima serie c'è il quadro portiere a centro strumentazione,qui non c'è più,non so nemmeno se con tutti i cablaggi sia possibile farla andare,so che in internet su ebay un venditore vendeva la plancia completa del Gta,con i relativi schemi per far funzionare la plancia,ma non li hai mai visti nessuno. Ci vuole un buon elettrauto con tanta tanta pazienza...e vi spennerà... ci sono ore di lavoro.
 

IRONMAN

Alfista principiante
15 Aprile 2006
114
0
23
37
TO
Regione
Piemonte
Alfa
GTV
Motore
2.0 twin spark
Re: computer alfa 156

Ciao ragazzi sono un nuovo iscritto del forum...ho seguito questo post perchè mi interessava.
Vi dico subito che ho montato l'infocenter su alfa 156 1.8 TS - 1° Serie.
L'installazione è semplicissima e la maggior parte dei collegamenti (Porte ANT. e POST. DX e SX, Baule, Alimentazione diretta e sottochiave e massa) vanno fatti al check centrale tra il tachimetro e il contagiri. Il pin per la temperatura olio motore (Solo per GTA - io non ho il sensore) non è collegato. I 4 pin per i tasti di controllo (+/-/info/set) me li sono installati a modo mio a parte. Il pin per il seriale con il climatizzatore l'ho collegato a un pin della centralina clima denominata M70 (dove avete le tre manopole..per intenderci) - questo pin e lo stesso utilizzato per la diagnosi del M70 e serve a trasmettere la temperatura esterna e segnalazione strada ghiacciata. Poi c'è un pin per l'interrutore inerziale. Và portato fino all'interuttore posto sotto al sedile guida- quando scatta l'interuttore l'infocenter lo segnala.

L'unico pin...ripeto l'unico che non posso collegare a nessuna parte e quello denominato "Seriale con tachimetro"!!! Questo influiva sul Trip Computer e quindi non posso avere le informazioni relative a velocità media, consumo, ecc., cioè quelle raggiungibili dal tasto SET !!

Sapete quindi qual'è la fregatura??? Il vero computer è il tachimetro della 2° serie !!!
Infatti a differenza di quello prima serie, Bypassa i segnali dello strumento carburante per farsi i suoi bravi calcoli e sputarli all'Infocenter.
Il Contagiri non è importante, ma il fatto sapete qual'è?? Se cambio il tachimetro devo mettere per forza quello con la luce rossa e faccio il quadro di picasso tra verde e rosso, sfondo bianco e sfondo nero. Dovrei cambiare inutilmente anche gli altri !

Cmq per il momento non fa niente !! Mi piace lo stesso. Ho tutte le informazioni tranne il Trip.

Mi interessava trovare gli At-commands seriali per capire come dialoga il pin seriale techimetro. Se qualche cervello si vuole unire...

Grazie e ciao.

grande....io vorrei proprio metterlo ma è pure difficile trovarlo!!!!prima o poi
 

clundestino

Alfista principiante
11 Settembre 2006
212
2
19
TO
Regione
Piemonte
Alfa
156
Motore
1800 TS
Re: computer alfa 156

ma scusate la torretta monta lo stesso sulla prima serie o bisogna modificare il foro
 

tazionuvolari

Alfista principiante
26 Febbraio 2007
102
0
16
AG
Regione
Sicilia
Alfa
159
Motore
1.9 Jdtm SW
Ciao ragazzi sono un nuovo iscritto del forum...ho seguito questo post perchè mi interessava.
Vi dico subito che ho montato l'infocenter su alfa 156 1.8 TS - 1° Serie.
L'installazione è semplicissima e la maggior parte dei collegamenti (Porte ANT. e POST. DX e SX, Baule, Alimentazione diretta e sottochiave e massa) vanno fatti al check centrale tra il tachimetro e il contagiri. Il pin per la temperatura olio motore (Solo per GTA - io non ho il sensore) non è collegato. I 4 pin per i tasti di controllo (+/-/info/set) me li sono installati a modo mio a parte. Il pin per il seriale con il climatizzatore l'ho collegato a un pin della centralina clima denominata M70 (dove avete le tre manopole..per intenderci) - questo pin e lo stesso utilizzato per la diagnosi del M70 e serve a trasmettere la temperatura esterna e segnalazione strada ghiacciata. Poi c'è un pin per l'interrutore inerziale. Và portato fino all'interuttore posto sotto al sedile guida- quando scatta l'interuttore l'infocenter lo segnala.

L'unico pin...ripeto l'unico che non posso collegare a nessuna parte e quello denominato "Seriale con tachimetro"!!! Questo influiva sul Trip Computer e quindi non posso avere le informazioni relative a velocità media, consumo, ecc., cioè quelle raggiungibili dal tasto SET !!

Sapete quindi qual'è la fregatura??? Il vero computer è il tachimetro della 2° serie !!!
Infatti a differenza di quello prima serie, Bypassa i segnali dello strumento carburante per farsi i suoi bravi calcoli e sputarli all'Infocenter.
Il Contagiri non è importante, ma il fatto sapete qual'è?? Se cambio il tachimetro devo mettere per forza quello con la luce rossa e faccio il quadro di picasso tra verde e rosso, sfondo bianco e sfondo nero. Dovrei cambiare inutilmente anche gli altri !

Cmq per il momento non fa niente !! Mi piace lo stesso. Ho tutte le informazioni tranne il Trip.

Mi interessava trovare gli At-commands seriali per capire come dialoga il pin seriale techimetro. Se qualche cervello si vuole unire...

Grazie e ciao.

Volevo chiederti una informazione...
Dove hai reperito la documentazione per effettuare i collegamenti richiesti?
Grazie e ciauz

ma scusate la torretta monta lo stesso sulla prima serie o bisogna modificare il foro

In quella che ho trovato io (su ebay), che dovrebbe essere della giugiaro, i fori non coincidono ma penso possa si ovviare al problema facendo dei nuovi fori.....
 
Ultima modifica da un moderatore:

peppealfa156

Nuovo Alfista
9 Febbraio 2008
26
0
1
TA
Regione
Puglia
Alfa
156
Motore
1.8 TS
Re: computer alfa 156

Riprendo il discorso fornendo alcune informazioni.

1) L'INFOCENTER con tutto il blocco bocchette aria si può adattare al cruscotto, occorre però allineare il fissaggio con le viti effettuando due ulteriori fori sul blocco. Ma non ci sono problemi perchè la sagoma è già presente.
2) Per quanto riguarda il montaggio del tachimetro della 2° serie, non ci sono problemi. Occorre soltanto fare delle inversioni di fili alle connessioni, perchè hanno cambiato alcune funzionalità. Infatti la spia airbag non è più presente nel tachimetro e quindi il filo che portava il segnale và spostato come connessione all'altro strumento. Insomma la cosa è fattibilissima, bisogna seguire solo gli schemi elettrici.
3) Se avete bisogno di informazioni chiedetemi pure. Ho gli schemi elettrici di tutta la vettura. Senza di quelli non avrei mai potuto montare l'INFOCENTER.

Dato che a me non interessa cambiare tutta la strumentazione, ma voglio abilitare a tutti i costi il trip sull'INFOCENTER ho pensato a due alternative:

1) Prelevo solo il circuito tachimetro 2° serie e lo adatto al mio fondino bianco a luce verde originale, ottenendo in tal modo il segnale di uscita CAN BUS che serve a pilotare il mio unico filo non connesso dell'INFOCENTER. Però devo studiare meglio la cosa.
2) Una soluzione più rapida è inserire il secondo tachimetro in maniera nascosto (solo circuito) inserendo solo in ingresso le connessioni importanti (Segnale velocità da ABS, segnale livello carburante, segnale da centralina); ottenendo in tal modo sempre il segnale che và a completare la funzionalità trip.
Mi sà tanto che questa soluzione mi gusta di più poichè non vado ad alterare gli strumenti che ho ed evito di cambiare tutto. La luce rossa dell'INFOCENTER non stona con il verde della mia 1° serie e si adatta al colore delle lancette rosse. E poi secondo me è più bello lo sfondo bianco. Cmq questione di gusti.

Per finire Aggiungo solo una cosa a cui mi stò dedicando (smanie di un perito elettronico :)):

L'INFOCENTER è stato realizzato da MAGNETI MARELLI e aprendolo ho studiato il microcontrollore che utilizza. E' un hitachi della famiglia H8S/2600 con precisione un microcontrollore a 16 bit siglato H86/2623. La mia intenzione è mappare la memoria per riscrivere il programma a piacere (provate solo a fantasticare sulla personalizzazione di un display a marice di punti niente male). Per ora ho in mano sia la documentazione che il software di programmazione flash adatto a trasferire il programma. Devo studiare solo la connessione alla seriale RS232 sfruttando i due cavi di diagnosi predisposti. Vi farò sapere.

Scusate per il post lunghetto. Ma và detto tutto.
 

Chi Siamo

  • L’obiettivo primario di Club Alfa è quello di riunire, in spirito di amicizia tutti i possessori di autovetture “Alfa Romeo”, ed i simpatizzanti, dotati di autovetture anche di altra casa automobilistica.
    Nata come community ispirata ai grandi forum d’oltreoceano, Club Alfa diventa rapidamente il luogo principale di aggregazione ed informazione del mondo Alfa Romeo e FCA.
    Maggiori Informazioni.

Funzioni Utente